Home > Jobfish > Quick Start Guide

Jobfish

Jobfish 2011 Quick Start Guide

Jobfish 2011 Quick Start Guide

1. Searching for a Job
Working with Jobfish makes working with a job board easier and faster with Jobfish than working with the job board directly. Jobfish supports two different types of job boards, HTML-based and XML/RSS-based, both seamlessly integrated, so you will notice very little difference.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Search for a New Job Wizard.JPG)

To get started, start Jobfish. Click on the "Search for a new job" navigation button on the left hand side directly below the calendar on the MySummary (Home) page.

You will be presented with the Job Search Wizard, as shown to the left. Select the job board desired. Jobfish will automatically launch the appropriate interface appropriate for the board. HTML based boards use the ‘Jobfish Board Import Console’, whereas XML/RSS based job boards use the XML/RSS Job Search wizard. As a shortcut, you can launch the Jobfish Board Import Console, by going to the Jobfish menu on the Start Menu. You must use this wizard to access the XML/RSS based boards.

Select the job board desired.

1.1. HTML Job Boards
The following is the current list of HTML boards supported by Jobfish.

CareerBuilder.com
CraigsList.com
Dice.com
HotJobs.com
JobALot.com
Monster.com

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish Board Import Console - Main.JPG)

In this example, CareerBuilder.com was selected. Once you select the option and click on the Next button, you will see Jobfish launch the Jobfish Board Import Console. Regardless of which job board you choose, you will see the main home page of the board displayed. In the screenshot to the left, "accounting" and "Los Angeles, CA" were entered into the main search fields, but you can enter whatever you want. The "Find Jobs" button was pressed, which yields the search results that you see.

Here is where Jobfish shines. Rather than clicking on each job opportunity and losing the search results or opening up a zillion browser windows, click on the "Load Search Results" button at the bottom. Before doing so, select how many search result pages you wish for Jobfish to load. In the example above, one page was selected to load, but you can select however many you want. Simply click on the up/down spin button to adjust the count. After clicking on the "Load Search Results" button, you will see the following parsed search results on the "View (Search Results) tab.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish Board Import Console - Import Step 2.JPG)

The spreadsheet at the top lists the search results with the data fields parsed, as you can see. Simply click on a new row to display the record.

You can view the record either below in the mini ‘Item in Browser’ tab in the lower left corner of the application, or if you said yes that you have dual monitor support (or via the Options button on the main tab), you can see the results on a separate window. Clicking on a new row updates both the little browser and the side browser. In either case, you do not lose the search results.

There are some nifty features that you can use. Jobfish allows you to hide selected rows from future search results. Simply select the row(s) desired and click on the ‘Hide Selected Results from Future Searches’ button located in the lower left corner. You might have to adjust the splitter to see all the buttons. You can restore all previously hidden records by clicking on the small dropdown menu next to the button and select the appropriate option.

If you want to delete some rows from the current search results, but not hide them from future searches, click on the dropdown menu next to the hide search results button and select the ‘Delete Row’ menu item.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish Board Import Console - Import Step 1.JPG)

You can get the next search results by clicking on the "Next Result Set". When there are no more search results, this button will appear grayed.

From here, there are two ways to proceed depending upon how you want to apply for the jobs. If you click directly on the Apply button on the website using either the side browser or the mini browser, you can click on the second column, "Did you apply for this job manually?" checkbox. You do not have to worry about losing the results with Jobfish, as you would with using the job board with Jobfish. Simply clicking on the next row brings up the next search result. You can also apply for the job later on, as will be discussed.

For jobs that you manually apply or for jobs that you want to import into your Jobfish database, check the box in the first column for that job opportunity labeled "Are you interested in this job?" After you check the box on the jobs that you want to store, as shown, click on the "Import Jobs" button.


 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish Board Import Console - Import Step 1.JPG)


You will see a progress bar, as shown to the left appear. Depending upon the speed of your internet connection and the number of job opportunities that you wish to import, this process might take a few seconds or a few minutes. When the import process completes, you will see the third tab, "Viewer (Posting Details)", as shown.


 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish Board Import Console - Import Step 3.JPG)

In the example shown, three (3) jobs were imported into the Jobfish database. The import process completed and you will see the status of the search in the third column, "Job in Jobfish Database". The text will show "Yes, Job ID [#]," where # will show the ID for the job imported. In the example, the IDs are 59, 60, and 61.

If you imported the jobs using the single method, ignore the "Import the Selected Jobs into Your Jobfish Database", as the jobs are already imported. You might have to adjust the splitter bar to full see the buttons.

The reason for the import button and the ‘Update Cell’ is that Jobfish allows users to edit the data prior to the import process. Many times it is easier to edit the results in a tabular grid and then do the import. If you wish to edit the data first before the physical creation of the job records in the Jobfish database, alter the steps that you took on the "View (Search Results) tab. Rather than click on the import button as you did, click on the dropdown menu to the side of the button. Click on the "Extract Job Details Only" menu item. Jobfish will then extract the data but will not do the import step. You can then press the import button on the third tab after you massage the data. Another reason for the button is that if for any reason one of the jobs does not import, you can fix the offending issue and then press the import button to try again for that job. Make sure to have checks in the first checkbox for only those jobs that you want to import and did not already import.

One reason that you might want to edit the records manually prior to importing them is to set the contact information or set any details of a job that might belong in one of the parsed fields available but was located in the description, so not readily parsed by Jobfish.

If you want to do another search, simply go back to the Main tab and start over, either with the same board or a different one.

If you had Jobfish open at the same time that you did the import into Jobfish using the Jobfish Board Import Console, the job list inside of Jobfish (MyJobs | MyJobs) will not show the jobs. That is because the list needs to be refreshed. Click on the refresh button directly above the table.

1.2. XML/RSS Based Job Boards
The following is a list of the current XML/RSS job boards supported by Jobfish.

Google.com
Indeed.com
JobCentral.com
SimplyHired.com
Vast.com

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - XMLRSS - Wizard Options.JPG)

If you select one of these boards, Jobfish will display the wizard indicated. You can specify the maximum number of job postings that you wish to download, the job board of interest (or all), search options, and other settings.

You have the option to download job postings from all XML/RSS based job boards or all job boards. To do so, click on the applicable option button in the lower right corner. To specify the number of job postings to download, simply enter that number in the "Maximum records per board (maximum is 500)" field in the wizard.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - XMLRSS - Search Results.JPG)

Users can set various search options by setting the values on various tabs. One thing to note is that not every job boards supports every search option.

Unlike HTML boards, where Jobfish captures the entire posting and then makes a best attempt to parse and present the data, XML/RSS boards by their nature provide limited feeds. Most, if not all, XML/RSS based job boards provide partial descriptions in their feed and expect that users click on the details button to view the full posting. Jobfish does attempt to solve this problem for the user, though. When looking at the final results in the preview dialog, Jobfish displays the actual posting.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - XMLRSS - Wizard.JPG)

Most XML/RSS job boards are not job boards in the sense of CareerBuilder.com and others. Indeed.com, Google, and the others are aggregators and display job opportunities from other boards. In this way, you will see duplicated listings, if you scan all boards.

The screen to the right shows the search results. In this example 34 job postings of the 45 were downloaded. Jobfish did some post filtering based upon the search options specified to create the final list shown.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - XMLRSS - Job Postings Preview.JPG)

Jobfish displays the resultant list in tabular format, but the easiest way to look at the results is to click on the preview toolbar button. That is the second button from the left directly above the table. You will be presented with the dialog shown.

As you can see, you are presented with the main web advertisement for you to look at with the parsed data on the other tabs.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Main Job List.JPG)

There are several key elements to note in the dialog. The first is the scrollbar at the bottom left. You can preview the different listings by moving the scrollbar. Jobfish indicates the current listing to the right of the scrollbar and the total number of listings directly above.

If you want to import any of the jobs, simply check the box, labeled "Check to mark for import" located directly above the Ok and Cancel buttons. You will see the total number of records that you selected for import in the field directly above the scrollbar labeled "To Import." You can also select jobs to import by checking the box on the main search results table next to the job opportunity indicated. To start the import process, click on the "Imported selected jobs into Jobfish" toolbar button located directly above the main search results.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Job Record Properties.JPG)

The screenshot above shows the main job list inside of Jobfish. If you are busy importing jobs and then go to this screen, you may not see your imported jobs listed. Do not worry. It is there in your database. Simply click on the refresh toolbar button located directly above the table.

You will notice on the screenshot above the popup menu. If you right click on any job record, you will see the popup menu as shown. That will give you the various tasks that you can do with respect to the job records. You also have the various actions located on the toolbar button.

If you open up the job record, you will expose yet other features. You can modify records, schedule interview, add and/or schedule interactions, set your presentation package, apply for jobs, mark your work status (resume sent, offer received, etc.)

One of the reasons for keeping track of your job status is for the statistical information. On the MyWorkspace | Motivation tab you can see various metrics. These metrics include:

Total number of job records
Number of job opportunities that you applied for
How many employers / recruiters contacted you back
How many interviews that you received
How many offers that you received
If any of these numbers are way off from what you expect, you will know which areas there are to work on. Knowledge is power and metrics and numbers are everything in a job search.

2. Working in the Recruiter and Employer Areas

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Recruiters.JPG)

The image to the left shows the recruiter / networking list inside of Jobfish. Jobfish offers pretty much the same features and task options for employers. As such, this quick start guide will not cover employers.

This table lists key information. Yan show or hide columns, as you desire. Simply go to the column properties toolbar button to adjust these settings.

This area offers a number of things that you can do or see from here.

View a list of job records from a recruiter
See the last called on date
See the callback on date
See the status (editable directly in the table)
Set up an interaction or an interview for a contact directly from this area without having to go to the job record.
Create a new job record from a contact
Go directly to the website
A very useful feature of Jobfish in this area is the ‘Job List’ option. Simply select the recruiter or employer of interest, select job list from either the context menu or the toolbar button and Jobfish will show you a list of jobs associated with this company. You will see the contact person in the resultant table. Simply click on the job of interest and click on the properties button. Jobfish will immediately open up the job record.

Why is this feature useful? If someone at the recruitment service or employer calls, they will assume that you know everything about their position. They will start talking to you about it. Having the information readily available, increases your chances of landing that interview, as you will know what to say.

Another thing to keep in mind is that many recruiters and employers, when the call, will assume that you do not know which position they are calling about. They will ask you what your strongest area is and what you want to do in your next job. They will give you their company name and their name, but otherwise you will be in the dark. Unless you know very quickly what position they are calling about, you will lose your opportunity to interview at the company. This feature gives you all relevant information at moment’s notice.

Many recruiters will tell you to contact them back at a certain time or tell you that they will contact you back at such and such a time. The chances are that they will not. If you deal with many recruiters, you will never get the follow-up and lose that opportunity. Making a good impression counts, and letting people know that you did not forget about them is key. They will see that you are interested. Simply schedule a task or enter the callback information here.

You can enter the status, a manual text field where you can enter whatever you want. This field will help you keep a quick note of important information that you see directly on the table associated with the employer and / or recruiter. You can clear your notes easily too from here and start over.

Another feature available is sending out multiple customized emails to your contacts, employment and recruitment based. Enter the body of the email in the Tools | Options | Recruiter tab or have Jobfish use your cover letter as the boilerplate with each salutation customized. Jobfish can send out many customized, also known as mail merge, emails complete with attached presentation packages.

3 Task List, Interactions, and Interviews
Jobfish provides a number of different scheduling and tracking options. The Task List available off of the MyWorkspace area. You can enter tasks easily, simply by entering the task directly on the form or clicking on the new task toolbar button and entering the information on an easy to use form.

Jobfish displays upcoming tasks, interactions, and interviews directly on the MySummary page. The MySummary page is your home page, where you can get a quick overview of your job search, quickly and easily.

If you have OfficeDove installed on your system, you can get notifications of your scheduled events (tasks, interactions, and interviews) be it by message box, tone, or audible voice if you have the Microsoft Speech Engine installed.

An interaction is any email, phone call, instant message, or other form of communication that you wish to log. Jobfish will associate all interactions and interviews with a job record. In that way, you can see all information related to a job opportunity. Knowing the history is important.

4 Presentation Packages

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Presentation Package Wizard.JPG)

No matter what your profession, more than likely you will have a few different styles of your resume, one tailored for a certain aspect. Each resume might have associated with it certain portfolio pieces that you want to share, a uniquely customized cover letter, an image, and maybe other attachments. Jobfish makes it easy to create presentation packages. A presentation package is an ensemble, a collective term used to denote your resume, cover letter, image, and other possible attachments and give them a unique name.

Click on the "Create/edit a resume package" from the "Work with your resume/cover letter" main navigation menu button to show the Presentation Package Wizard. From here you can create or delete presentation packages by clicking on the new and delete button. Enter a name for the presentation package and select the documents that you wish to associate with the package.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Email.JPG)

To associate a job record with a presentation package, you can use the "Attach a resume package to a job record" from the "Work with your resume and cover letter" main navigation menu system. Jobfish will display a list of job records. Select the job record in question, and Jobfish will take care of the rest. Alternatively, you can open up the job record and select the presentation package from the dropdown list.

Once you have a presentation package to a job and you have an email address attached to either an employer or recruitment contact for the job record, you can apply for the job via email directly from within Jobfish. Open up the job record, go to either the employer or recruiter property, and select the contact. From there, click the email contact button on the toolbar directly above the contact list. Jobfish will display the screen shown.

Jobfish will keep a copy of the email attached to the job record shown as an interaction. Jobfish will also update the resume sent and date resume sent date automatically, if this email is the first one sent for the job record for your convenience.

Jobfish has a built-in SMTP server that it can use, but sometimes especially with hotmail and other free accounts sending emails can be problematic. In those cases enter the SMTP POP3 server information for your email address. Go to the Tools | Options | Email dialog. Be sure to take off the checkmark that says use built-in SMTP server first checkbox. Also, make sure to select this email address as the default.

To apply for a job, click on the "Apply to a job in your Jobfish database" directly from within Jobfish. Jobfish will display a list of job records. Select the job record that you want to apply to. From here one of three things will happen. If you have only the built-in apply for job URL extracted from the job posting associated with the job record, Jobfish will open up an external browser to the apply-to page for you to apply to the job. If you have only an email address associated with the job record, Jobfish will display the email interface for you to apply for the job opportunity this way. Jobfish naturally keeps track of the email as an interaction. If you have both a URL and an email address, Jobfish will ask you wish method you want to use to apply for the job and then act accordingly. Jobfish will update the resume sent and date resume sent fields inside the job record upon you successfully applying for the job.

5 The Important Things :-)

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Select Skin.JPG)

No matter how good an application is, if you use the application you want it to look good. Jobfish is skinnable in one of several different ways. You can select a different outer skin by clicking on the inner most bubble in the upper right corner of the application to the lef of the minimize button. That displays the change skin dialog. There are numerous skins available for you to choose.

For the other part of Jobfish, you can select one of several different themes. Jobfish automatically defaults to the Microsoft Office 2007 theme, but you can select one of several, simply by clicking on the desired theme on the main toolbar or under by going to the Tools | Themes menu. The Tools menu offers other customization options.

6 Why Use Jobfish?
Even if you have a connection, be it a friend or relative, who is itching to give you a new job, do you not owe it to yourself to give yourself the best possible new job possible?

Searching for a job is a tedious process, and using the job boards is even more tedious, if not turning off. Jobfish is a better interface to job boards then using them directly. Even if you just apply for the jobs directly through the board, job boards keep reposting the same data, make viewing results difficult, and applying not that easy. Jobfish simplifies the process and takes away nothing of the original experience. Jobfish adds to it.

Working with recruitment firms is also easy with Jobfish. You can use Jobfish even for your networking contacts. Keep track of when you have to call them and the last time that the two of you talked. Keep track of your job tasks and things that recruiters might want you to do.

Keeping track of multiple resumes is also easier with Jobfish. Creating presentation packages and sending them out without gathering them each and every time is now simpler with Jobfish, be it one at a time or in mass using the mail merge feature in Jobfish.

Jobfish gives you reports, be it to file for EDD, or for yourself. There are a number of reports directly accessible from the MySummary (Home) page.

 (image: http://wiki.butterflyvista.com/Images/Products/Jobfish/Screenshots/Jobfish - Database Console.JPG)

For advanced users, Jobfish provides raw access to the underlying SQL database using the Jobfish Database Console. On the View tab, you can select the table of interest. Simply select the rows that you want, copy the contents to the clipboard (or export the table to a CSV file format), and you then into whatever application you choose. If you only want some rows or the most recent, simply sort the table by the column desired, select the rows of interest, and copy the information to the clipboard.

You can perform a database backup. Backup files are stored in the same folder as your mail database files. You can see the folder from the main tab of the Microsoft Database Console.

We hope that this brief quick start guide gives you a flavor of what you can do with Jobfish and how to get you started. Explore the product and all the various options available to you. If you get stuck, contact us and we will be happy to answer your questions. There are no dumb questions, other than not asking something that you want to ask. Let Jobfish help you.

If you have any questions or comments, please contact us by visiting our website at:

http://www.butterflyvista.com/

Alternatively, you can use the contact us form directly within Jobfish. Select the Technical Support option off of the Help menu. Jobfish will open up a pre-filled in email box ready for you to type.